pencil tracing issues

All topics related to RhinoCAM

pencil tracing issues

Postby arch-cnc » Mon Mar 01, 2010 2:36 pm

i have modeled a stepped topography for an architectural model. i am having an impossible time getting the pencil tracing to generate correctly. i takes forever, and the output is poor. the current problem (other then taking obscene amounts of time to generate) is that in the middle of a contour line it will stop, pick the bit up, transit somewhere else, eventually come back and then skip a small section and continue on. it also wont get all the way to the edges of the model. looking for suggestions.
arch-cnc
 
Posts: 2
Joined: Thu Feb 18, 2010 11:06 pm

Postby Mitch Heynick » Mon Mar 01, 2010 3:42 pm

I think you're unlikely to get the results you want with pencil tracing, especially if you have complex contours like topography. The "skip" phenomenon is likely due to small meshing defects that wreak havoc with the bi-tangent calculation... The calculation time is probably normal for the volume and quality of the data...

I have a friend who mills architectural models like this in VM - I think he uses horizontal finishing with a flat end mill and the same depth step as the contour lines.

The other way to do this is with 2D profiling... Extract your contours and check your start points, then use the geometry as "top" and the depth as your step size.

--Mitch
Mitch Heynick
 
Posts: 489
Joined: Wed Aug 01, 2007 4:15 pm
Location: Switzerland

Postby arch-cnc » Mon Mar 01, 2010 3:57 pm

thanks mitch. in the meantime since the post (openly venting frustration and whining gives plenty of time for reconsideration of methods) i did try the horizontal finishing with the same depths as the contours. worked great, exactly what i wanted in the first place and processed much faster. however as a follow up question to the horizontal finishing, i can't get it to clear flats. clicking the clear flats box seems to have no affect. i may be misunderstanding what the clear flats feature is, but i was assuming that it would machine larger flat areas.
arch-cnc
 
Posts: 2
Joined: Thu Feb 18, 2010 11:06 pm

Postby nscott » Mon Mar 29, 2010 4:07 pm

What clear flats does is to make an extra pass at the level of any horizontal surface. Unfortunately it isn't very smart because it will make an extra pass if there is a horizontal surface anywhere on the model even if it isn't in the region you are machining. This can result in many, many extra necessary passes.

Nick
nscott
 
Posts: 54
Joined: Wed Aug 01, 2007 4:15 pm
Location: vancouver, canada

Postby JVidal » Fri Apr 30, 2010 3:55 am

Hi,

I'm also having trouble with the pencil tracing on VisualMILL.

Are you using a round tool? Apparently VM is not very fond of computing a pencil tracing MOP if the tool and fillet radius are similar or if the tool radius is smaller than the fillet radius.

I run some tests using the 3Axis_Example1.vcp on the tutorials folder.

Using a round tool (diam = 3mm, which is smaller than the fillets) the calculation times are through the roof (cancelled after 3 hours!), however if I try with a 10mm round tool - which is larger than the fillets - it's a lot faster (1-2 minutes).

I believe there is something wrong with this MOP, however the general computation speed is not very good. Even with simpler MOPS like roughing or horizontal finishing the toolpath generation takes too long.
Best regards
JVidal
JVidal
 
Posts: 72
Joined: Fri Jan 08, 2010 7:38 am
Location: Portugal

Postby MecSoft Support » Fri Apr 30, 2010 11:53 am

We ran tests on pencil tracing for the 3Axis_Example1.vcp part and here are the results.
Ball Mill – 3MM

Test#1:
Intol/Outol = 0.1
Stock =0
Do multiple cuts =2
Step over = 20 % tool diameter
Time to generate toolpath averages between 40- 60 seconds

Test#2:
Intol/Outol = 0.03
All other settings remain the same as above
Time to generate toolpath averages between 2 minute 40 seconds - 3 minute 25 seconds

Ball Mill – 4MM

Test#3:
Intol/outol = 0.1
Stock =0
Do multiple cuts =2
Step over = 20 % tool diameter
Time to generate toolpath averages between 30- 45 seconds

Test#4:
Intol/outol = 0.03
All other settings remain the same as above
Time to generate toolpath averages between 1 minute 45 seconds - 2 minute 20 seconds

You could try un-installing & reinstalling VisualCAM 1.0 and VisualMILL 6.0 to see if this resolves the issue on your end.
MecSoft Support
 
Posts: 2461
Joined: Wed Aug 01, 2007 4:15 pm
Location: Irvine, CA, USA

Re: pencil tracing issues

Postby ebartlet » Tue Jul 31, 2012 2:24 am

Hi,

Similar problem. I have a contoured stepped terrain model, all lovely clean surfaces. The horizontal finishing is excellent but it won't clear the remaining stock on each surface. Did you guys ever resolve this?

Thanks

Ed
ebartlet
 
Posts: 2
Joined: Thu Feb 09, 2012 4:35 am


Return to RhinoCAM Topics & Support

Who is online

Users browsing this forum: Google [Bot] and 0 guests

cron