Error Handling Parabolas

All discussion related to VisualCAM for SolidWorks

Error Handling Parabolas

Postby Bryce » Tue Sep 06, 2011 8:04 am

I've discovered an error with how VM4SW handles parabolas. If a parabola is selected as a curve, it simply does not exist to Visual Mill. Here I have selected the curves defining the extruded feature, and the parabola is skipped, and an open loop is cut. When I use the same sketch as the boundary of a pocketing operation, I get an open loops error message.

VM4SW_Parabola_Error_Curve.JPG
Select curve
VM4SW_Parabola_Error_Curve.JPG (26.29 KiB) Viewed 9474 times


If I select the flat area, the operation completes correctly.

VM4SW_Parabola_Error_Flat_Area.JPG
Select flat area
VM4SW_Parabola_Error_Flat_Area.JPG (26.32 KiB) Viewed 9474 times


However, a flat area is often inconvenient or impractical. Is there a solution that would allow a user to use curve parabolas in VM4SW?
Attachments
VM4SW_Parabola_Error.SLDPRT
(333.5 KiB) Downloaded 844 times
Bryce
 
Posts: 13
Joined: Tue Mar 09, 2010 8:18 am

Re: Error Handling Parabolas

Postby MecSoft Support » Tue Sep 06, 2011 10:41 am

We will take a look at it and get back to you.
MecSoft Support
 
Posts: 2464
Joined: Wed Aug 01, 2007 4:15 pm
Location: Irvine, CA, USA

Re: Error Handling Parabolas

Postby Bryce » Tue Sep 06, 2011 12:02 pm

Thanks. I appreciate that. Parabolas seem to come up a lot when we get geometry imported from Adobe Illustrator artwork.
Bryce
 
Posts: 13
Joined: Tue Mar 09, 2010 8:18 am

Re: Error Handling Parabolas

Postby Bryce » Sat Apr 14, 2012 2:40 pm

I'm currently working on another project where vector data was imported from Adobe Illustrator. It has thousands of little parabola vectors that I planned to engrave. I'm not really sure what to do about this. More than a year later, this bug still isn't fixed.
Bryce
 
Posts: 13
Joined: Tue Mar 09, 2010 8:18 am

Re: Error Handling Parabolas

Postby MecSoft Support » Tue Apr 17, 2012 8:30 am

This bug has been fixed in our upcoming 2012 release. We will be releasing a beta in the next few days.
MecSoft Support
 
Posts: 2464
Joined: Wed Aug 01, 2007 4:15 pm
Location: Irvine, CA, USA


Return to VisualCAM for SolidWorks Topics & Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron